読者です 読者をやめる 読者になる 読者になる

開発のヒホ

iOSとかAndroidとかのアプリを開発するのに四苦八苦するブログ

Xcode6でLocalizable.stringsを設定するとCould not load NIB in bundle

Xcode4時代と同じようにLocalizable.stringsを作ると、 Could not load NIB in bundleエラーが出てアプリが起動しなくなりました。 最近はプロジェクトファイルのinfoの下の方にある Use Base Internationalizationをチェックするのが普通だそうな。 これで…

AAMFeedbackがiOS8でバグるのをなんとかする

AAMFeedback・・・昔はいろいろと重宝されておりました・・・ 参考 → iOSアプリ開発者が知らないと損するライブラリ7選 - Paradigm Shift Design 私もまぁ未だに使わせてもらっていますが・・・ 表示がバグる・・・ 最後のコミットが2 years agoという過去の遺物ですが、…

presentPopoverFromBarButtonItemでwhich is already presentingエラー

iOS8、相変わらずちょくちょく仕様変更がされていますね。 ふと昔のアプリを使ってみると微妙に動かない場所が見つかったりします。 今回のアップデートで、UINavigationBarItemから出していたUIPopoverControllerが表示されないようになってしまいました。 …

iOS8用アプリを申請しようとするとエラーが出る

Xcode6で、iOS8用に作りなおしたアプリをアップデート申請しようとすると、 ditto: Couldn't read PKZip Signature Unable to extract archive. unable to extract archive ... ... is a valid zip or ipa archive とかなんとか言われて怒られました。 なん…

iOS8でライブラリのFlatUIを使うとエラーが出る

prefix attribute must be followed by an interface or protocol とのこと。 この辺りがひっかかっていました。 #import <UIKit/UIKit.h> @interface UINavigationBar (FlatUI) - (void) configureFlatNavigationBarWithColor:(UIColor *)color ; UI_APPEARANCE_SELECTOR @</uikit/uikit.h>…